Opened 12 years ago

Last modified 12 years ago

#7 accepted defect

Error when creating new branch

Reported by: stier Owned by: ros
Priority: major Milestone:
Component: General Version: 6.3
Keywords: Cc: rosalindwest, sosprey

Description

Hi Ros, I have just tried to set up a new branch through the fcm gui and have encountered the following problem after pressing the Run button:

vn6.3: revision keyword not found for  in FCM configuration file, abort.

vn6.3 is specified in the Source revision field. However, when I look into my .fcm file it reads

 more ~/.fcm 
inc ~um/fcm/etc/um_revisions.cfg

and this refers to

cat  ~um/fcm/etc/um_revisions.cfg
set::revision::UM_TUTORIAL::vn6.3    24

So it looks like this should be found. Any idea what is going wrong?

Many thanks, Philip

Change History (6)

comment:1 in reply to: ↑ description Changed 12 years ago by stier

I should have maybe added the resulting fcm command that the gui created from my input. Here we go:

 fcm branch -c --svn-non-interactive -n MyTestBranch -t DEV --rev-flag NORMAL -r vn6.3 -k #6 fcm:um_tutorial --password ""

comment:2 Changed 12 years ago by ros

  • Status changed from new to assigned

I'm rather confused! I just got a colleague here who's never used the Tutorial repository and it's worked ok for her (including the --password "" option)

Could you try again and omit the --password ""? I find that if I add this option I get the same symptoms as you. For some reason I believe the system already recognised you're a valid user of the subversion repository and so doesn't need the password option.

comment:3 Changed 12 years ago by stier

Thanks for looking into this Ros. Well, this is what I have started with - and I have just retried: when I do not specify the --password option then I am getting the following error:

# Start: 2008-05-19 10:24:48=> fcm branch -c --svn-non-interactive -n MyTestBranch -t DEV --rev-flag NORMAL -r vn6.3 -k #6 fcm:um_tutorial
Starting emacs to edit commit message ...
Commit message is as follows:
--------------------------------------------------------------------------------
Creating UM tutorial test branch "MyTestBranch"

Created /UM/branches/dev/stier/VN6.3_MyTestBranch from /UM/trunk@24.
Relates to ticket #6.
--This line, and those below, will be ignored--
A    svn://puma/UM_TUTORIAL_svn/UM/branches/dev/stier/VN6.3_MyTestBranch
--------------------------------------------------------------------------------
Creating sub-directory: branches/dev/stier
svn: Can't get password
svn mkdir -m 'Created branches/dev/stier directory.' --non-interactive svn://puma/UM_TUTORIAL_svn/UM/branches/dev/stier failed (1) at /home/um/fcm/lib/Fcm/CmBranch.pm line 840
"fcm branch -c --svn-non-interactive -n MyTestBranch -t DEV --rev-flag NORMAL -r vn6.3 -k #6 fcm:um_tutorial" failed (7424)
# Time taken:           27 s=> fcm branch -c --svn-non-interactive -n MyTestBranch -t DEV --rev-flag NORMAL -r vn6.3 -k #6 fcm:um_tutorial

I hope this helps.

Philip

comment:4 Changed 12 years ago by stier

Hi Ros, one more update. I just retried with Scott and we ran into the same problem from this account.

Cheers, Philip

comment:5 Changed 12 years ago by ros

Ok. I think I've found the problem. Put the --password "" back in and make sure that in the field labelled "Related Trac tickets" you don't have the # before the number. I've recreated your problem with a test user and it's the # that's causing the problems. FCM automatically adds the # in this case.

Cheers, Ros.

comment:6 Changed 12 years ago by stier

Thanks Ros.

It finally worked after I restarted fcm gui and did as you advised (no success without the restart). The second time I also did not modify the comment, not sure if that might have had an effect.

Philip

Note: See TracTickets for help on using tickets.